Home > Reporting Services > Reporting Service 2008 Install – “Input String was not in a correct format.”

Reporting Service 2008 Install – “Input String was not in a correct format.”

I got this error the other day whilst trying to install Reporting services.

After much digging I found this blog entry that fixed it:
http://social.msdn.microsoft.com/forums/en-US/sqlsetupandupgrade/thread/c9cb944d-6264-4530-9e00-ee92da3e939f/

In short the performance counters on the machine were corrupted, so the following command rebuilt them and fixed the RS Install error.

c:\windows\system32\lodctr /R

RS was left in a half installed state:

  • it was unable to be installed because it thought it was already installed
  • it was unable to repair cause it said it was not installed
  • Solution was to run the command above, uninstall, (I removed all SQL Server 2008 components) and re-install from scratch.

    Advertisements
    Categories: Reporting Services
    1. 12 February, 2010 at 8:01 pm

      Nice..
      Please visit my blog

      https://kapgemini.wordpress.com

      Kapil

    1. No trackbacks yet.

    Leave a Reply

    Fill in your details below or click an icon to log in:

    WordPress.com Logo

    You are commenting using your WordPress.com account. Log Out / Change )

    Twitter picture

    You are commenting using your Twitter account. Log Out / Change )

    Facebook photo

    You are commenting using your Facebook account. Log Out / Change )

    Google+ photo

    You are commenting using your Google+ account. Log Out / Change )

    Connecting to %s

    %d bloggers like this: